Commit 85218417 authored by Renato Figueiro Maia's avatar Renato Figueiro Maia

[OPENBUS-2723] Permitir utilizar funções padrão de Lua no arquivo de configuração do 'busservices'

- Correção para permitir que a função 'require' disponivel no arquivo de configuração.


git-svn-id: https://subversion.tecgraf.puc-rio.br/engdist/openbus/sdk/lua/branches/02_00_00@161242 ae0415b3-e90b-0410-900d-d0be9363c56b
parent 820a8325
......@@ -170,6 +170,7 @@ function module.create()
local ok, result = xpcall(require, traceback, name)
package.path, package.cpath = path, cpath
if not ok then error(result) end
module = result
else
error("no permission to load module '"..name.."'")
end
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment