[OPENBUS-3150] Dependências diretas adicionadas e junit-jupiter corrigido para...

[OPENBUS-3150] Dependências diretas adicionadas e junit-jupiter corrigido para ser executado em conjunto com o maven
parent 2fbc38bb
......@@ -42,6 +42,11 @@
<artifactId>javautils-core</artifactId>
</dependency>
<dependency>
<groupId>com.google.guava</groupId>
<artifactId>guava</artifactId>
</dependency>
<dependency>
<groupId>org.junit.jupiter</groupId>
<artifactId>junit-jupiter-engine</artifactId>
......
......@@ -103,6 +103,18 @@
<artifactId>miglayout-swing</artifactId>
</dependency>
<dependency>
<groupId>org.jacorb</groupId>
<artifactId>jacorb</artifactId>
<version>3.9</version>
</dependency>
<dependency>
<groupId>br.puc-rio.tecgraf.openbus</groupId>
<artifactId>openbus-sdk-legacy</artifactId>
<version>2.1.1.2</version>
</dependency>
<dependency>
<groupId>org.apache.poi</groupId>
<artifactId>poi-ooxml</artifactId>
......@@ -115,17 +127,9 @@
<version>7.5.2</version>
</dependency>
<dependency>
<groupId>org.junit</groupId>
<artifactId>junit-bom</artifactId>
<type>bom</type>
</dependency>
<dependency>
<groupId>org.junit.jupiter</groupId>
<artifactId>junit-jupiter-engine</artifactId>
<version>5.3.1</version>
<scope>test</scope>
</dependency>
......
......@@ -15,7 +15,8 @@
<javautils.version>4.0.0</javautils.version>
<javautils.gui.version>5.0.1</javautils.gui.version>
<jacorb.version>3.8</jacorb.version>
<junit.version>5.3.1</junit.version>
<junit.version>5.4.1</junit.version>
<guava.version>19.0</guava.version>
<miglayout.version>4.2</miglayout.version>
<openbus-sdk.version>2.1.1.2-SNAPSHOT</openbus-sdk.version>
<governance.version>1.0.1-SNAPSHOT</governance.version>
......@@ -49,6 +50,12 @@
<build>
<plugins>
<plugin>
<artifactId>maven-surefire-plugin</artifactId>
<version>2.22.1</version>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-release-plugin</artifactId>
......@@ -58,7 +65,7 @@
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<version>2.3.2</version>
<version>3.8.0</version>
<configuration>
<source>${java.version}</source>
<target>${java.version}</target>
......@@ -139,14 +146,21 @@
<version>${miglayout.version}</version>
</dependency>
<dependency>
<groupId>com.google.guava</groupId>
<artifactId>guava</artifactId>
<version>${guava.version}</version>
</dependency>
<dependency>
<groupId>org.junit</groupId>
<artifactId>junit-bom</artifactId>
<version>${junit.version}</version>
<type>bom</type>
<scope>test</scope>
<type>pom</type>
<scope>import</scope>
</dependency>
</dependencies>
</dependencyManagement>
</project>
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment