OPENBUS-3149 O issue foi formatado em três itens diferentes, ficando explícito...

OPENBUS-3149 O issue foi formatado em três itens diferentes, ficando explícito para o desenvolvedor quais são os projetos e o que ele deve fazer em cada um para construi-los
parent 9b1ceb25
......@@ -13,11 +13,19 @@
`---` `---'.| \ \ /'---' | | ,' `--`----' `--'---'
`---` `----' `----'
** Docker OpenBus Development Environment 2018 - PUC-Rio
Compile: 'b2 warnings=off -sOPENSSL_INSTALL=$OPENSSL_PACKAGE_DIR -sOPENLDAP_INSTALL=$OPENLDAP_PACKAGE_DIR -sUUID_INSTALL=$LIBUUID_PACKAGE_DIR threading=multi'
Use same compile directive for the following projects:
- openbus-core
- openbus-governance-extension
* openbus-core
Build dir....: /openbus-dev/packages/openbus-core/bbuild
Compile......: b2 warnings=off -sOPENSSL_INSTALL=$OPENSSL_PACKAGE_DIR -sOPENLDAP_INSTALL=$OPENLDAP_PACKAGE_DIR -sUUID_INSTALL=$LIBUUID_PACKAGE_DIR threading=multi
In order to compile the 'openbus-collaboration-service' project you may use a couple of alternative variables since it's dependent of OpenBus 2.0 protocol.
Compile: 'b2 warnings=off -sOPENSSL_INSTALL=$OPENSSL_PACKAGE_DIR -sOPENLDAP_INSTALL=$OPENLDAP_PACKAGE_DIR -sUUID_INSTALL=$LIBUUID_PACKAGE_DIR -sLUAOPENBUS=/openbus-dev/packages/luaopenbus-v20 -sOPENBUS_LEGACY_IDL=/openbus-dev/packages/openbus-legacy-idl-v15 -sOPENBUS_LIB_IDL=/openbus-dev/packages/openbus-lib-idl-v20 -sOPENBUS_IDL=/openbus-dev/packages/openbus-legacy-idl threading=multi'
* openbus-governance-extension
Build dir....: /openbus-dev/packages/openbus-governance-extension/bbuild
Compile......: b2 warnings=off -sOPENSSL_INSTALL=$OPENSSL_PACKAGE_DIR -sOPENLDAP_INSTALL=$OPENLDAP_PACKAGE_DIR -sUUID_INSTALL=$LIBUUID_PACKAGE_DIR threading=multi
* openbus-collaboration-service
Build dir....: /openbus-dev/packages/openbus-collaboration-service/bbuild
Description..: In order to compile the 'openbus-collaboration-service' project
you may use a couple of alternative variables since it's
dependent of OpenBus 2.0 protocol.
Compile......: b2 warnings=off -sOPENSSL_INSTALL=$OPENSSL_PACKAGE_DIR -sOPENLDAP_INSTALL=$OPENLDAP_PACKAGE_DIR -sUUID_INSTALL=$LIBUUID_PACKAGE_DIR -sLUAOPENBUS=/openbus-dev/packages/luaopenbus-v20 -sOPENBUS_LEGACY_IDL=/openbus-dev/packages/openbus-legacy-idl-v15 -sOPENBUS_LIB_IDL=/openbus-dev/packages/openbus-lib-idl-v20 -sOPENBUS_IDL=/openbus-dev/packages/openbus-legacy-idl threading=multi
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment